股票实盘配资平台

同花顺CCI超跌战法副图指标公式(附源码破译和源码)

发布日期:2024-01-25 06:28    点击次数:202

编程思路破译

TYP赋值:(最高价+最低价+收盘价)/3

输出CCI:(TYP-TYP的14日简单移动平均)/(0.015*TYP的14日平均绝对偏差),线宽为2,COLOR456456

输出绝情谷:CCI<-150 ,线宽为0

当满足条件绝情谷时,在CCI和-10位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLOR0011FF

当满足条件绝情谷时,在CCI和-10位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR0044FF

当满足条件绝情谷时,在CCI和-10位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLOR0077FF

当满足条件绝情谷时,在CCI和-10位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR0099FF

当满足条件绝情谷时,在CCI位置书写文字,COLOR0000FF

输出桃花岛:成交量(手)的5日简单移动平均上穿成交量(手)的20日简单移动平均*5,线宽为0,COLORFF00FF

当满足条件桃花岛时,在0和60位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLOR330033

当满足条件桃花岛时,在0和60位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR770077

当满足条件桃花岛时,在0和60位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLORBB00BB

当满足条件桃花岛时,在0和60位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLORFF00FF

输出逃离铁掌帮:200上穿CCI AND 2日前的CCI<1日前的CCI AND CCI<1日前的CCI 

当满足条件逃离铁掌帮时,在0和120位置之间画柱状线,宽度为2.7,0不为0则画空心柱.,COLOR003300

当满足条件逃离铁掌帮时,在0和120位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR007700

当满足条件逃离铁掌帮时,在0和120位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLOR00BB00

当满足条件逃离铁掌帮时,在0和120位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR00FF00

当满足条件逃离铁掌帮时,在CCI位置书写文字,COLORFFFFFF

程序源码

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK2,COLOR456456;

绝情谷:CCI<-150 ,LINETHICK0;

STICKLINE(绝情谷,CCI,-10,2.7,0),COLOR0011FF;

STICKLINE(绝情谷,CCI,-10,1.8,0),COLOR0044FF;

STICKLINE(绝情谷,CCI,-10,0.9,0),COLOR0077FF;

STICKLINE(绝情谷,CCI,-10,0.1,0),COLOR0099FF;

DRAWTEXT(绝情谷,CCI,'绝情谷'),COLOR0000FF;

桃花岛:CROSS(MA(V,5),MA(V,20))*5,LINETHICK0,COLORFF00FF;

STICKLINE(桃花岛,0,60,2.7,0),COLOR330033;

STICKLINE(桃花岛,0,60,1.8,0),COLOR770077;

STICKLINE(桃花岛,0,60,0.9,0),COLORBB00BB;

STICKLINE(桃花岛,0,60,0.1,0),COLORFF00FF;

逃离铁掌帮:CROSS(200,CCI) AND REF(CCI,2)<REF(CCI,1) AND CCI<REF(CCI,1) ;

STICKLINE(逃离铁掌帮,0,120,2.7,0),COLOR003300;

STICKLINE(逃离铁掌帮,0,120,1.8,0),COLOR007700;

STICKLINE(逃离铁掌帮,0,120,0.9,0),COLOR00BB00;

STICKLINE(逃离铁掌帮,0,120,0.1,0),COLOR00FF00;

DRAWTEXT(逃离铁掌帮,CCI,'铁掌帮'),COLORFFFFFF;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。

上一篇:因原料成本上涨等 金龙鱼2021年净利润下滑逾三成
下一篇:恒指收跌0.35% 生物医药股走低